To get access to the attachments Subscribe now

Thread Rating:
  • 5 Vote(s) - 3.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FaceBook Connect plugin
(12-06-2012, 05:48 AM)Lennart Wrote:
(12-05-2012, 11:15 PM)echofloripa Wrote: Right, now I configured a self-signed certificate and I still get the exactly same error.
No detailed reason even with the

You will need a proper SSL certificate, not sure if facebook does accept self-signed certificates.


According to this post:

http://stackoverflow.com/questions/73194...canvas-url

"I have tested with a self signed cert, and it works fine without browser warning in Chrome but fails in Firefox"

Just don't want to buy a certificate to then see it wasn't the problem...
Also, look at this

http://www.sourcecoast.com/jfbconnect/do...r-facebook

[cite]Please Note: An SSL certificate is not required for user authentication on your site, Likes, Comments or other things. It's only used if you want to show your site (or parts of it) inside the Facebook.com domain.[/cite]

So it seems the problem is a different one.

I just checked on facebook's own login with facebook guide, and it never mentions anything about SSL:

https://developers.facebook.com/docs/how...ide-login/

Please help me, I have tons of users out of my forum and can't ask them to re-register again.
Reply
This is the bit of code in fbconnect that shows the error I am seeing:

Quote: //If we don't have the name from facebook something is terribly wrong here!
if(!$fbme[name]){
error($lang->fbconnect_error_nousername, $lang->fbconnect_error_signup);
exit;
}
Reply
I'd really appreciate if someone could help me with this...
Reply
I have the same problem. I have installed a real SSL certificate (provided by StartSSL.com), but I get the same error when I try to login with Facebook: "No username detected!".

My forum is at https://forum.quantifiedself.com

It seems that the problem is NOT related to SSL. It seems the plugin stopped working. Maybe Facebook changed their API?

Lennart, an answer would be appreciated.
Reply
All:

I have solved the broken Facebook login issue. Here's how to fix it.

1. The cause of the "No username detected" error is that Facebook updated their [Image: external.png]PHP API/SDK. It has nothing to do with SSL.

The changes that concern us are that getSession() has become obsolete (unnecessary) and setSession(null) is now destroySession().

Here's what a user needs to do:

  1. Edit fbconnect.php and look for the "$clearsession = $facebook->..." line. Make it read
    "$clearsession = $facebook->destroySession();".
  2. Edit fbmain.php and match it to look like this:

    Edit by admin: I removed your code as it is deprecated and should not be used in production. Please update to the latest version of the plugin.

  3. [Image: external.png]Download from GitHub base_facebook.php in the same directory as fbconnect.php (/inc/plugins)
  4. Overwrite facebook.php with [Image: external.png]the new one from GitHub.

That's it. I hope Lennart will update the plugin ASAP. I've spent about 6 hours total fighting with this issue (most of it wasted trying to install SSL certificates), so I hope I'll get a copy of the new plugin.
Reply
Thanks very much dandv, I did as you said, I can now login but it shows the following message:

Edit by admin: I removed your message as it could reveal information about your server. Please update to the latest version of the plugin.
Reply
I got the same error at some point, and if I remember correctly, the problem was with fbmain.php. Here's my fbmain.php:

Edit by admin: I removed your link because it is an deprecated version of the file. Please do no longer use this version in production.
Reply
I updated this plugin to version 1.5.

Version 1.5 includes a french language pack (Thanks to Namish!) and some changes to meet facebook's new api requirements. It also includes the newest facebook api.
The comment form on index has been removed (no longer supported by fb) as well as all settings that belonged to api keys.

To cleanup the confusion here: You do need SSL to run this plugin in most countries! There might be some people or countries that can run facebook apps without https but most people need SSL encryption. This has been tested on german business sites for a while.

People who do have the google connect plugin and the facebook connect plugin installed do need to update both plugins. Because of the new naming conventions, the plugins are interferring with each other when connecting google / facebook via oauth2. This has been fixed now.
People who do not have installed the google connect plugin are also welcome to update the facebook connect plugin to the latest version.

The first post has been updated accordingly.
Forum Admin
Reply
Warning [2] session_start(): Cannot send session cache limiter - headers already sent (output started at /home/XXXX/public_html/admin/inc/class_page.php:131) - Line: 49 - File: inc/plugins/facebook.php PHP 5.3.15 (Linux)
File Line Function
[PHP] errorHandler->error
/inc/plugins/facebook.php 49 session_start
/inc/plugins/fbmain.php 18 Facebook->__construct
/admin/modules/config/plugins.php 477 require_once
/admin/index.php 497 require


one more google connect i canot activate?????????
Reply
Where do you get this error please?
Forum Admin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)